Role Detail

geerlingguy.php-memcached

PHP Memcached support for Linux
Downloads
23855
Type Ansible
Minimum Ansible Version 1.8
Installation $ ansible-galaxy install geerlingguy.php-memcached
Tags
database
web
Last Commit 2017-04-02 14:49:02 PM UTC
Last Imported 2017-04-02 14:59:02 PM UTC
Version History
Version Release Date
2.0.0 2016-05-12 14:04:02 PM
1.1.0 2016-03-06 03:26:03 AM
1.0.1 2014-11-11 16:41:04 PM
1.0.0 2014-10-13 15:32:03 PM
Supported Platforms
Platform Version
Debian etch
Debian jessie
Debian lenny
Debian sid
Debian squeeze
Debian stretch
Debian wheezy
EL 6
EL 7
Ubuntu lucid
Ubuntu maverick
Ubuntu natty
Ubuntu oneiric
Ubuntu precise
Ubuntu quantal
Ubuntu raring
Ubuntu saucy
Ubuntu trusty
Ubuntu utopic
Ubuntu vivid
Ubuntu wily
Ubuntu xenial
Ubuntu yakkety
Dependencies
Role
Last 10 Imports
Completed Status
2017-04-02 14:59:02 PM UTC SUCCESS
2017-01-22 03:43:03 AM UTC SUCCESS
2016-11-02 20:21:08 PM UTC SUCCESS
2016-09-25 22:29:10 PM UTC SUCCESS
2016-09-15 03:08:03 AM UTC SUCCESS
2016-09-15 02:51:02 AM UTC SUCCESS
2016-06-09 17:28:05 PM UTC SUCCESS
2016-05-12 14:31:02 PM UTC SUCCESS
2016-05-12 14:16:02 PM UTC SUCCESS
2016-05-12 14:14:02 PM UTC SUCCESS

Ansible Role: PHP-Memcached

Build Status

Installs PHP Memcached support on RedHat/CentOS/Debian/Ubuntu.

Requirements

This role doesn't explicitly require Memcached to be installed, but if you don't have the daemon running somewhere (either on the same server, or somewhere else), this role won't be all that helpful. Check out geerlingguy.memcached for a simple role to install and configure Memcached (either on the same server, or separate servers).

Role Variables

Available variables are listed below, along with default values (see defaults/main.yml):

php_enablerepo: ""

(RedHat/CentOS only) If you have enabled any additional repositories (might I suggest geerlingguy.repo-epel or geerlingguy.repo-remi), those repositories can be listed under this variable (e.g. remi,epel). This can be handy, as an example, if you want to install the latest version of PHP from Remi's repository.

php_memcached_package: php-memcached

The package to install for PHP Memcached support. For Debian/Ubuntu and PHP 5.x, use php5-memcached.

Dependencies

  • geerlingguy.php

Example Playbook

- hosts: webservers
  roles:
    - { role: geerlingguy.php-memcached }

License

MIT / BSD

Author Information

This role was created in 2014 by Jeff Geerling, author of Ansible for DevOps.

None